2010-12-16 5 views
1

Je construis une application pour mon entreprise en utilisant la version 5 du SDK Symbian s60. Ma question est de savoir si elle fonctionnera sur les téléphones avec le système d'exploitation Symbian s60 version 1 ou non?Symbian - L'application s60 version 5 fonctionne-t-elle sur la version s60 1

(je suis conscient que la compatibilité inverse ne fonctionne pas, mais juste des éclaircissements que j'ai posté ce)

Répondre

2

Non, absolument pas. En fait, S60 v1 n'est même pas rétrocompatible avec v5 (il y avait une rupture de compatibilité binaire majeure à S60 3ème édition).

Si vous avez besoin de S60 v1, vous avez du travail à faire - il y a beaucoup de pauses et de changements d'API à faire.

Si vous souhaitez augmenter la couverture du marché, vous pouvez utiliser la S60 3rd Edition, qui vous donnera la compatibilité avec S60 5ème édition.

+0

Sauf si @Satyam sw signifiait Symbian^1 au lieu de S60 1.x. Symbian^1 est essentiellement le même que S60 5th Edition et donc compatible binaire. – laalto

+0

Bon point. @Satyam - Avez-vous voulu dire S60 1ère édition, ou Symbian^1? Ils sont très différents. – KevinD

Questions connexes