2017-10-21 32 views
-1

Salut, j'ai installé le noeud v2.2.6 et npm 3.5.2 dans mon ubuntu mais maintenant quand j'essaye d'installer la dernière version ou node6.x alors je reçois quelques erreurs dans mon terminal des paquets 404 non trouvés. J'ai également joint la capture d'écran. s'il vous plaît laissez-moi savoir comment puis-je le réparer?Comment installer node8 et le dernier npm dans ubuntu

j'ai aussi essayé: -

curl -sL https://deb.nodesource.com/setup_0.12 | sudo bash - 
# Then install with: 
sudo apt-get install -y nodejs 

encore obtenu la même sortie et je suppose que je fait une erreur en exécutant une commande: -

sudo sed -i -e 's/:\/\/(archive.ubuntu.com\|security.ubuntu.com)/old-releases.ubuntu.com/g' /etc/apt/sources.list 

comme mentionné dans https://smyl.es/how-to-fix-ubuntudebian-apt-get-404-not-found-package-repository-errors-saucy-raring-quantal-oneiric-natty/

Here is the output of sudo apt-get update

Répondre

0

Je suggère d'utiliser nvm en tant que gestionnaire nodejs et npm. Ensuite, vous pouvez facilement installer la version requise de nœud avec NVM installer noeud xx commande

+0

Thanx son :) travaillé –

0

je ne sais pas quelle est votre version ubuntu mais si elle est sur 16,4 vous pouvez faire des commandes:

$ sudo apt-get update 
$ sudo apt-get install build-essential libssl-dev 

après:

$ curl -sL https://raw.githubusercontent.com/creationix/nvm/v0.31.0/install.sh -o install_nvm.sh 

et après faire cette commande:

$ nano install_nvm.sh 

et après que fermer la nano et faire cette commande:

$ bash install_nvm.sh 

Il va installer le logiciel dans un sous-répertoire de votre répertoire personnel ~/.nvm. Il ajoutera également les lignes nécessaires à votre fichier ~/.profile pour utiliser le fichier.

Pour accéder à la fonctionnalité de NVM, vous devez vous déconnecter et vous reconnecter, ou vous pouvez localiser le fichier ~/.profile afin que votre session connaît les changements:

$ source ~/.profile 

maintenant Si vous avez installé nvm, vous pouvez installer des versions isolées de Node.js.

Pour connaître les versions de Node.js qui sont disponibles pour l'installation, vous pouvez taper:

$ nvm ls-remote 

et eteint ressemble à ceci:

.... 
v5.8.0 
v5.9.0 
v5.9.1 
v5.10.0 
v5.10.1 
v5.11.0 
v6.0.0 
... 
v8.4.0 

vous pouvez simplement taper cette commande pour installer le v8.4.0 de nodejs:

$ nvm install 8.4.0 

et à la dernière étape, vous pouvez taper cette commande pour utiliser la dernière version:

$ nvm use 8.4.0 

et il est fait!